Log in

Unable to start game (black screen) at https://empireofcode.com/game/

  • 13 Nov '16

Errors at console in Chrome Version 54.0.2840.87 (64-bit) and Safari Version 10.0.2 (12602.3.3) on macOS Sierra 10.12.2 Beta (16C32f).

empireofcode.com/:1 WebSocket connection to 'wss://empireofcode.com/ws/main/?EIO=3&transport=websocket' failed: WebSocket is closed before the connection is established.

https://analytics.empireofcode.com/?clientId=null&username=null&data=send%2…ent%2Csystem%2Creconnecting&tag=%3Btt%3Dalgo_chance%3Bta%3D0%3B&raw=%7B%7D Failed to load resource: net::ERR_CONNECTION_REFUSED

  • 13 Nov '16

Looks like it's fixed now!

I have the same kind of problem : black screen at https://empireofcode.com/game/

What can I do ?

Chrome console :
WebSocket connection to 'wss://empireofcode.com/ws/main/?EIO=3&transport=websocket' failed: Error during WebSocket handshake: Unexpected response code: 500

r @ vendors.js:4

  • 13 Jan

At first the page - https://empireofcode.com/game/ loaded to a black screen with the error -
VM2006:35 WebSocket connection to 'wss://empireofcode.com/ws/main/?EIO=3&transport=websocket' failed: Error during WebSocket handshake: Unexpected response code: 500

I disabled adblock and the page seemed like it was going to load but then gave me the same error..

More details -

shadow = document.documentElement.createShadowRoot(); - Calling Element.createShadowRoot() for an element which already hosts a shadow root is deprecated. See https://www.chromestatus.com/features/4668884095336448 for more detail.

VM2006:35 WebSocket connection to 'wss://empireofcode.com/ws/main/?EIO=3&transport=websocket' failed: Error during WebSocket handshake: Unexpected response code: 500
WrappedWebSocket @ VM2006:35
WrappedWebSocket @ VM2025:35
r @ vendors.js:4
r.doOpen @ vendors.js:3
r.open @ vendors.js:3
r.open @ vendors.js:3
r @ vendors.js:2
r @ vendors.js:2
r.open.r.connect @ vendors.js:2
(anonymous) @ vendors.js:2

I have the same. Black screen for new game, and Server Error (500) for back/login

  • 8 Apr

Server down..

  • 9 Apr

I'm getting this too still, was getting it earlier today also.

Im having a black screen as well, Firefox console shows me this:
Firefox can’t establish a connection to the server at wss://empireofcode.com/ws/main/?EIO=3&transport=websocket.

this:
The connection to wss://empireofcode.com/ws/main/?EIO=3&transport=websocket was interrupted while the page was loading.

and this:
Strict-Transport-Security: The site specified a header that could not be parsed successfully.

  • 9 Apr

Still down.., well.. we can't blame them.. it is Beta..

  • 9 Apr

The same problem with black screen.
Chrome browser.

  • 9 Apr

Hi, it's my turn now, I can't login. Black screen. Since 3 days.
Server is down?

  • 10 Apr

@ryuzaki01,
It might be beta but A) it's been around a year and a half, and B) they do have paying customers! Hopefully whoever runs this was just offline for the weekend without a backup person and they'll notice it or the extra "Contact Us" messages Monday morning.

  • 10 Apr

Same websocket server error here on Chrome.

  • 10 Apr

Monday morning has come around and still black screen.

  • 11 Apr

no news.. almost a week.. i'm willing to help the team if they needed it.. i'm sure you guys too...

  • 11 Apr

Looks like it's back to working.
I had to explicitly re-login to get my former character.

  • 24 Jul

Same problem, socket error, code 500, etc.

  • 24 Jul

Same problem, socket error, code 500, etc.

  • 24 Jul

Same here, since yesterday 22:00 CET

  • 24 Jul

Once I managed to run, but now again black screen.

Reply